Eloquencer reset ou...
 
Notifications
Clear all

Eloquencer reset out issue/misunderstanding  

  RSS

Mattbodom
(@mattbodom)
Active Member
Joined: 3 weeks ago
Posts: 7
09/01/2021 11:48 pm  

Hi everyone, 

I have recently got my hands on an Eloquencer along side the EME module and I'm loving it.

One thing that's baffling me though, is that I am also trying to clock and reset a Z8000 Matrix sequencer. My setup is as follows

Elektron Analog Rytm Mk2 Midi out > EME Midi in which is connected to the Eloquencer.

I then have the clock out of the Eloquencer going into the clock of the Z8000 and the Aux out of the Eloquencer going to reset in of the Z8000.

The Rytm and Eloquencer are perfectly in sync, however the Z8000 is always 1 step ahead and it starts on step 2 (Changing AUX to trigger on stop and Play high etc make no difference)

 

The only way I have managed to get around this is to use a spare track on the eloquencer to send a single gate to the Z8000 reset input at the start of each track and that works perfectly

 

If anyone has any advice it would be massively appreciated, thanks.

 

Matt

 


Quote
dayjob
(@dayjob)
New Member
Joined: 1 week ago
Posts: 2
11/01/2021 1:57 am  

set the aux out to "trigg reset on stop".  


ReplyQuote
Mattbodom
(@mattbodom)
Active Member
Joined: 3 weeks ago
Posts: 7
11/01/2021 2:09 am  

@dayjob Thanks for your reply, but this doesn't fix the issue unfortunately. The only way around for now, was to use a spare track to send a single gate at the start of the bar, into the reset of the Z8000.


ReplyQuote
dayjob
(@dayjob)
New Member
Joined: 1 week ago
Posts: 2
11/01/2021 3:35 am  
Posted by: @mattbodom

@dayjob Thanks for your reply, but this doesn't fix the issue unfortunately. The only way around for now, was to use a spare track to send a single gate at the start of the bar, into the reset of the Z8000.

that's weird. 'reset on stop' should make everything sync up so when you press play again it all starts together. what happens if you take your rytm out of the chain and make the eloquencer the main clock? 


ReplyQuote
WinterModular
(@wintermodular)
Member Admin
Joined: 2 years ago
Posts: 368
11/01/2021 12:41 pm  

Hi @mattbodom !
My first answer was going to be the one that @dayjob proposed, but it seems it doesn't work... 🙁
It is possible we are facing the typical event sequence issue. Some sequencers can act different depending if they receive the reset trigger before the clock or vice versa. In this case, when you press stop in your Rytm the Eloquencer sends a trigger to the Z8000, so it jumps to its first step. ( I don't know the Z8000, do you have any kind of feedback to know that this is happening?) Let's assume that this is happening, and the Z8000 is in its first step, maybe the problem is that before it receives the first clock trigger it is already in the first step, and when receives the first clock trigger it jumps to the second step.
In my case (considering the Eloquencer as slave) I do a different approach, If I receive a reset the Eloquencer goes to an imaginary step 0 and it does not jump to step 1 until it receives a clock. I think this is the best way to keep things in sync, but I understand somebody can thing the other way.
A way to check this behavior: if you have something that can easily generate gates when you want (like buttons that generate gates) try to reproduce this behavior in slow motion 🙂 You need two gate generating buttons attached to Z8000 reset and clock inputs. Press the 'clock button' to emulate the clock running and check that each time you press it, it jumps to the next step, then press the 'reset button' and see what happens, then press the first clock and see what happens.

If this is the behavior, Could you please try something ? Change the aux configuration to playH/stopL, try if it works (I assume it won't because you say you have already test this configuration also) then add a gate delay between the Eloq Aux out and the Z8000 Reset in, (if you don't have a gate delay you can use an Envelope Generator with a little bit of attack. Does it work ?


ReplyQuote
Mattbodom
(@mattbodom)
Active Member
Joined: 3 weeks ago
Posts: 7
13/01/2021 1:54 am  

@dayjob Thanks for the reply, it seems that the Z8000 is starting on step 2 (Step 1 being used by the reset trigger if that makes sense) Like wintermodular have also replied. Using the Eloquencer as master doesn't alter anything unfortunately.

thanks again


ReplyQuote
Mattbodom
(@mattbodom)
Active Member
Joined: 3 weeks ago
Posts: 7
13/01/2021 2:06 am  

@wintermodular Thankyou for the reply. yeah, it seems that the Z8000 is starting on step 2 for some reason. When i hit stop on the Eloquencer or Rytm the Z8000 jumps to step 1 and the first time the sequence is played, step 1 isn't audible so its 100% not playing step 1.

 

I have just tried what you asked (Had to use an envelope generator with slow attack) And this worked. I then tried straight from the AUX output to the Z8000 and it was starting on the 2nd step again.

What does this mean? Are there any settings on the Eloquencer that i can change to solve this? So i don't have to use a spare track from the Eloquencer or an external envelope generator?

Thanks again, i appreciate your help 🙂

EDITED: I have a Behringer system 100 173 Gate and multiple module but no manual triggers. Is there a way this could be used instead of an envelope? No attenuators on the module though

This post was modified 1 week ago by Mattbodom

ReplyQuote
Mattbodom
(@mattbodom)
Active Member
Joined: 3 weeks ago
Posts: 7
13/01/2021 2:34 am  

FIXED:

Unless anyone from @wintermodular advises against it, i think i have found a fix. When setting the AUX out of the Eloquencer, on the 'Gate' option, i didn't realise that the buttons indicated where in the sequence you want to send a gate. I Now have it setup so that the AUX of the eloquencer is sending a gate on step 1 to the Z8000 instead of Track H which i was using to send a gate before. This way, all sequencing is done from ELO and leaves my tracks free and no other modules needed.

 

Perfect, not sure how i missed this, think i was focused more on the Play/stop and End settings

 

Thankyou


ReplyQuote
WinterModular
(@wintermodular)
Member Admin
Joined: 2 years ago
Posts: 368
13/01/2021 10:43 am  

@mattbodom yeah ! It is a very interesting solution ! 🙂
I don't remember exactly how is programmed but the aux gates are probably delayed in relation with the clock, so you have found a solution with the same approach I was proposing ! :)) Well done !
I think this 'sort of reset' will be attached to the master track configuration.


ReplyQuote
Mattbodom
(@mattbodom)
Active Member
Joined: 3 weeks ago
Posts: 7
14/01/2021 1:17 am  

@wintermodular Perfect! Thankyou


ReplyQuote