Midi in rec deletin...
 
Notifications

Midi in rec deleting other track  

  RSS

kilowatt
(@kilowatt)
Active Member
Joined: 1 year ago
Posts: 16
11/05/2020 10:58 pm  

My 1.3.8 elo/EME is deleting another track when I switch from one track to the other in free play mode after recording with midi in record.  I explain everything in this video I made:

https://youtu.be/NY5QQZJnqZk

This topic was modified 2 weeks ago by kilowatt

Quote
Topic Tags
WinterModular
(@wintermodular)
Member Admin
Joined: 1 year ago
Posts: 250
12/05/2020 3:27 pm  

wow !! I think you are the first one to find this.

Will solve it and add it in the next fw !

Thanks for the feedback !


ReplyQuote
WinterModular
(@wintermodular)
Member Admin
Joined: 1 year ago
Posts: 250
12/05/2020 4:30 pm  

Hi again @kilowatt !

I only found one way to reproduce the issue, it is related with TIE, when you change the rec mode and a note is still on, when changing the track the previous recorded track understands that is receiving a TIE because it hasn't received a 'note off' message

While you got the loop playing in the keystep, you leave the recording changing the other track, so the track that was recording has receive a 'note on' but hasn't received a 'note off'  message so it understands there is TIE going on, so it delete everything that is inside the TIE.

I will try to remove TIE flags when changing the LIVE REC mode.


ReplyQuote
kilowatt
(@kilowatt)
Active Member
Joined: 1 year ago
Posts: 16
12/05/2020 4:42 pm  

@wintermodular ohhh thanks Eloi ! That should fix it then !  Because this midi in rec feature is so important for fast live recording !

 


ReplyQuote