Eloquencer v1.3.8 F...
 
Notifications
Clear all

[Sticky] Eloquencer v1.3.8 FW update  

  RSS

WinterModular
(@wintermodular)
Member Admin
Joined: 1 year ago
Posts: 289
22/08/2019 12:16 pm  

This version must be used if using a second batch EME unit (EME serial number starting at 2 or higher)

https://github.com/enoughframes/ELOQUENCER___UPDATER

ELOQUENCER FW v 1.3.8 Release notes

  • THIS VERSION MUST BE USED IF USING EME EXPANSION FROM BATCH 2 or HIGHER (serial number starting at 2)
  • Add new 'pattern reset: first' configuration. Allows to reset the pattern only the first time it is played (coming from another pattern)
  • Solved. User scales from 2 to 8 can't be chosen using a MIDI interface (CH1 CC22)
  • The 'CV in' reading process has been modified to improve the CV in tracking.
  • Improve tha pattern chain start.
  • Duplicate and copy paste will now copy the scale group
  • Trk length display description added.

Quote
pyrolator1
(@pyrolator1)
New Member
Joined: 10 months ago
Posts: 4
18/10/2019 1:37 pm  

Hi,

I just received my EME and wanted to update my Eloquencer to 1.3.8 (my serial is 4218 with FW 1.2).

My computer doesn´t recognize the USB-Port. I tried 2 different Laptops (Mac) and three different cables  - the updater doesn´t show the " removed link ", do you have any hint for me, what I am doing wrong?

best wishes

Kurt

 


ReplyQuote
pyrolator1
(@pyrolator1)
New Member
Joined: 10 months ago
Posts: 4
18/10/2019 3:27 pm  

Hi,

 

never mind, used a different cable (no.4 😉 ) and it worked. thank you for this wonderful sequencer.....


ReplyQuote
WinterModular
(@wintermodular)
Member Admin
Joined: 1 year ago
Posts: 289
21/10/2019 9:11 am  

Great !

Sorry for late response, I don't know why your message was hidden by the automatic censorship.


ReplyQuote
hockthelosthawk
(@hockthelosthawk)
Active Member
Joined: 8 months ago
Posts: 10
05/12/2019 9:51 pm  

possible bugs?

[1] CV add does not seem to respect negative voltage,

-5/+5V set on the back and in SW option.  CV on track  turned to 50%, negative voltage has no impact on CV out, positive value does.

 

[2] CV add cannot work w/ tracks that have LFO mode enabled. not sure if that's intended/compatible or not

 

 


ReplyQuote
WinterModular
(@wintermodular)
Member Admin
Joined: 1 year ago
Posts: 289
09/12/2019 9:19 am  

Hi @hockthelosthawk,

Thanks for the feedback!

Regarding 1) : it is not a bug, negative values are no implemented in 2 specific modes (CV add and CV Q). Those CV in modes are related with tuning / tracking so we considered to make it only positive.

Regarding  2):  it is not a feature for a similar reason, CV add and CV Q are more related with tracking / tuning, and LFO is a non-quantized signal so at the end we decide to separate them. Anyway, we are planning to add new CV in assigns for the next upcoming update, one of them will probably be the LFO offset that I think that will have the same effect that you are looking for ( and will probably allow un-quantize values).

 

 


ReplyQuote
FJL
 FJL
(@fjl)
Active Member
Joined: 10 months ago
Posts: 9
12/03/2020 11:39 pm  

Hey @wintermodular

any updates concerning the update? it would be seriously cool, if it comes out soon. really dont want to put any stress on you, and i guess i couldnt. but still, i got this sequencer for live performances, and still it is not 100% usable for me. 1) deleting chained patterns per track and 2) midi in tracking is off in pitch and timing. 

i would be really happy if you could give some information on a possible release date,

 

thank you a lot,

 

FJL


ReplyQuote
WinterModular
(@wintermodular)
Member Admin
Joined: 1 year ago
Posts: 289
13/03/2020 11:13 am  

Hi @fjl !

1) deleting chained tracks is currently working in the upcoming firmware release.

2) I don't understand what do you mean, could you please give me more details ?

I need to finish the last big new feature and then I'm planning to release a beta version here in the forum.

 

 

 


ReplyQuote
FJL
 FJL
(@fjl)
Active Member
Joined: 10 months ago
Posts: 9
13/03/2020 12:36 pm  

@wintermodular sounds awesome! thanks 🙂

 

concerning 2, i had some issues when entering modes in live recording via a midi keyboard. a sustained noted stopped abruptly when the recording was played back, even though the recorded information should have been a sustained note. i mentioned this earlier in a comment and you said you will adress it, so i guess i just didnt make it clear enough this time. i would be happy if you just check out this post again:

 

"hey you at winter modular.i have a couple of severe problems concerning live performances with my device. unfortunately i cannot find a solution on my own. therefore i am hoping that you could make some time to answer a couple of questions i have: 1) Gate ties are not recorded correctly, sometimes the recording seems to be interrupted which leads to super short gates being recorded. 2) deleting a track over multiple patterns is really a pain in the a**. i have to correctly time hitting the track button 4 times to delete it over a length of 4 patterns. 3) i cannot record an arpeggiated sequence via the keystep, since hitting start/stop interrupts the pattern of the eloquencer even though the clock is set to internal. it is connected via usb. it really seems to me, that these things are really minor, but still in total they completely take out the flow of performing live for me. i would be very very, really, very happy if you could help me with it. thanks a lot and greetings from germany UPDATE* hey mate. i found something that hopefully helps to figure out a solution for the problem concerning the gate ties: it seems that if you hit multiple keys on the keystep in a fast and upfollowing order, the gate gets registered on the first key hit. meaning, that if i want to play for example a fast pattern of key 1,2,3, that is faster than 16th notes, the second key is following the gate of key 1, but with different pitch. that leads to the fact, that if i release key 1, the gate closes and key 2 is not playing anymore. do you know what i mean? it really would mean a lot to me if you could figure out a solution, or just tell me that i am stupid and didnt go over the options correctly. what would be necessary to solve this is, i think, is recording/registering a new gate with every new pitch coming in. or is it possible that the quantizing behaviour of incoming gate/pitch information is somehow not bug-free? i dont know if it has to do with eme aswell? Anyways, i have some gigs coming up soon: help please!!! "😀 Thank you man.


ReplyQuote
WinterModular
(@wintermodular)
Member Admin
Joined: 1 year ago
Posts: 289
13/03/2020 12:56 pm  

Ahh! yes! the multiple press issue is already solved ! I didn't understand the first time.

The octave issue is more related with Eloquencer eurorack/midi notation difference. In Eloquencer I use a notation more related with voltage, so C0 is 0 Volts, when implementing MIDI in EME I tried to follow this notation so message note 0x00 is related with Eloquencer C0 that is 0 V, but this notation does not match the MIDI notation where message 0x00 is related to octave -1 or -2 (depends on the documentation you check).


ReplyQuote